downgrade 4.0.1 a 3.1.2